CVE-2026-9800 · GHSA-f5p5-6xmx-p252
Keycloak vulnerable to authorization bypass via incorrect uri comparison
- Risk score
- 64/100
- CVSS
- 8.1 v3.1
- Exploit chance (30 days)
- 0.7%
- Published
- 25 Jun 2026
Open in the live forecast Today's forecast
What to know
- What it is
- Keycloak Policy Enforcer has a flaw that allows any authenticated user to bypass authorization policies by including the access-denied page path in a request URL. This allows unauthorized access to protected resources.
- Affected
- {'products': ['Keycloak'], 'packages': [{'ecosystem': 'maven', 'name': 'org.keycloak:keycloak-services', 'vulnerable': '< 26.6.4'}, {'ecosystem': 'maven', 'name': 'org.keycloak:keycloak-policy-enforcer', 'vulnerable': '< 26.0.10'}]}
- Fix
- Upgrade to version 26.6.4 for keycloak-services or 26.0.10 for keycloak-policy-enforcer
- Exploitation
- No known exploitation
Story map
At a glance
org.keycloak:keycloak-services: Amber, patch this week. Keycloak Policy Enforcer has a flaw that allows any authenticated user to bypass authorization policies by including the access-denied page path in a request URL. This allows unauthorized access to protected resources.
The flaws
- CVE-2026-9800: Keycloak vulnerable to authorization bypass via incorrect uri comparison (CVSS 8.1 · EPSS 1%)
- CVE-2026-9086: Keycloak vulnerable to cross-site scripting (xss) via case-insensitive uri validation bypass (CVSS 7.3 · EPSS 1%)
- CVE-2026-9705: Keycloak: Attacker can re-enable and take over disabled clients via registration access token (CVSS 6.5 · EPSS 0%)
- CVE-2026-9083: Keycloak vulnerable to information disclosure through arbitrary filesystem path probing (CVSS 4.9 · EPSS 1%)
The fix
Fix: Upgrade to version 26.6.4 for keycloak-services or 26.0.10 for keycloak-policy-enforcer
Who is exposed: {'products': ['Keycloak'], 'packages': [{'ecosystem': 'maven', 'name': 'org.keycloak:keycloak-services', 'vulnerable': '< 26.6.4'}, {'ecosystem': 'maven', 'name': 'org.keycloak:keycloak-policy-enforcer', 'vulnerable': '< 26.0.10'}]}
Where it stands
- No known exploitation
Connects to
- Same weakness: CWE-1025 (CWE-1025). 4 other warnings in 30 days
- Same product: Earlier org.keycloak:keycloak-services warnings. 1 in the last 90 days
Why it is Amber
- CVSS 8.1 high
- On your watchlist: Maven
Affected packages
| Package | Ecosystem | Vulnerable | Fixed in |
|---|---|---|---|
| org.keycloak:keycloak-services | maven | < 26.6.4 | 26.6.4 |
| org.keycloak:keycloak-policy-enforcer | maven | < 26.0.10 | 26.0.10 |
References
- https://github.com/advisories/GHSA-f5p5-6xmx-p252
- https://github.com/keycloak/keycloak/security/advisories/GHSA-f5p5-6xmx-p252
- https://nvd.nist.gov/vuln/detail/CVE-2026-9800
- https://access.redhat.com/errata/RHSA-2026:30049
- https://access.redhat.com/errata/RHSA-2026:30050
- https://access.redhat.com/errata/RHSA-2026:30083
- https://access.redhat.com/errata/RHSA-2026:30084
- https://access.redhat.com/errata/RHSA-2026:36002
- https://access.redhat.com/errata/RHSA-2026:36013
- https://access.redhat.com/errata/RHSA-2026:50846
Original description
A flaw was found in Keycloak Policy Enforcer. This vulnerability allows any authenticated user to bypass all authorization policies, including role, scope, and User-Managed Access (UMA) permission checks. By including the configured access-denied page path within a request URL, either as a path segment or a query parameter, an attacker can gain unauthorized access to protected resources.
Last activity 29 Oct 2026. Patch Forecast updates every hour.