Patch Forecast
Amber warning
Patch this week.

CVE-2026-94624 · GHSA-frvg-qw88-hww9

vllm p2p never connected zmq_exhaustion

Risk score
65/100
CVSS
7.5 v3.1
Exploit chance (30 days)
0.6%
Published
21 Sep 2026

Open in the live forecast Today's forecast

What to know

What it is
vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port values in kv_transfer_params to create unreachable peer sessions that retain ZeroM…
Affected
vllm (pip) < 0.32.0
Fix
Upgrade vllm to 0.32.0 or later.
Exploitation
No known exploitation

Story map

Story map: vllmTHE FLAWSTHE FIXCVE-2026-94624Vllm p2p never connectedzmq_exhaustionCVSS 7.5 · EPSS 1%CVE-2026-100652Improper input validationCVSS 7.5 · EPSS 0%CVE-2026-105759VLLM is an inference andserving engine for largelanguage modelsCVSS 7.5 · EPSS 0%CVE-2026-103241Denial of serviceCVSS 7.5 · EPSS 1%Upgrade vllm0.30.0or later on your release lineWho is exposedvllm (pip) < 0.32.0AMBER · PATCH THIS WEEKvllmvLLM through 0.29.0 contains adenial of service vulnerability inP2P KV offloading whenOffloadingConnector isconfigured withTieringOffloadingSpec and apeer-to-peer secondary tier.…Where it standsPublic proof of conceptCONNECTS TOSame weaknessDenial of service (CWE-770)225 other warnings in 30 days →Same productEarlier vllm warnings16 in the last 90 days →
Story map: the flaws, the fix, how it unfolded and what it connects to. Boxes link to the record or article.

At a glance

vllm: Amber, patch this week. vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port values in kv_transfer_params to create unreachable peer sessions that retain ZeroM…

The flaws

  • CVE-2026-94624: Vllm p2p never connected zmq_exhaustion (CVSS 7.5 · EPSS 1%)
  • CVE-2026-100652: Improper input validation (CVSS 7.5 · EPSS 0%)
  • CVE-2026-105759: VLLM is an inference and serving engine for large language models (CVSS 7.5 · EPSS 0%)
  • CVE-2026-103241: Denial of service (CVSS 7.5 · EPSS 1%)

The fix

Upgrade vllm: 0.30.0 or later on your release line

Who is exposed: vllm (pip) < 0.32.0

Where it stands

  • Public proof of concept

Connects to

Why it is Amber

  • CVSS 7.5 high
  • Remotely exploitable without logging in
  • On your watchlist: PyPI

Affected packages

PackageEcosystemVulnerableFixed in
vllmpip< 0.32.00.32.0

References

Original description

vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port values in kv_transfer_params to create unreachable peer sessions that retain ZeroMQ sockets until the context quota is exhausted, causing an uncaught ZMQError that crashes EngineCore and stops all inference.

Last activity 27 Oct 2026. Patch Forecast updates every hour.