Patch Forecast
Yellow warning
Plan into this sprint.

CVE-2026-85315

Apache Camel: information disclosure

Risk score
40/100
CVSS
5.3 v3.1
Exploit chance (30 days)
0.5%
Published
19 Oct 2026

Open in the live forecast Today's forecast

What to know

What it is
Generation of Error Message Containing Sensitive Information vulnerability in Apache Camel gRPC component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. When a route behind a gRPC consumer failed, the exception's message was placed into the gRPC status description. Unlike the st…
Affected
Apache Camel before 4.18.5, 4.22.1
Fix
Upgrade Apache Camel to 4.18.5 or 4.22.1 (whichever matches your release line), or later.
Exploitation
No known exploitation

Story map

Story map: Apache CamelTHE FLAWSTHE FIXCVE-2026-85315Information disclosureCVSS 5.3 · EPSS 0%CVE-2026-79986Path traversalCVSS 9.1 · EPSS 1%CVE-2026-78162Unsafe deserialisation can leadto remote code executionCVSS 9.8 · EPSS 1%CVE-2026-79983Path traversalCVSS 9.1 · EPSS 1%Upgrade Apache Camel4.18.5 · 4.22.1 · 4.23.0or later on your release lineWho is exposed{'products': ['Apache Camel'],'packages': [], 'versions': ['4.0.0before 4.18.5', '4.19.0 before4.22.1']}RED · ACT TODAYApache CamelApache Camel has a 'PathTraversal' vulnerability in itsAzure Files component, allowingan attacker to access filesoutside the intended directory.An attacker could read, write,or delete files on the remote…Where it standsNo known exploitationCONNECTS TOSame weaknessCWE-209 (CWE-209)23 other warnings in 30 days →Same productEarlier Apache Camel warnings23 in the last 90 days →
Story map: the flaws, the fix, how it unfolded and what it connects to. Boxes link to the record or article.

At a glance

Apache Camel: Red, act today. Apache Camel has a 'Path Traversal' vulnerability in its Azure Files component, allowing an attacker to access files outside the intended directory. An attacker could read, write, or delete files on the remote server.

The flaws

The fix

Upgrade Apache Camel: 4.18.5 · 4.22.1 · 4.23.0 or later on your release line

Who is exposed: {'products': ['Apache Camel'], 'packages': [], 'versions': ['4.0.0 before 4.18.5', '4.19.0 before 4.22.1']}

Where it stands

  • No known exploitation

Connects to

Why it is Yellow

  • CVSS 5.3 medium

References

Original description

Generation of Error Message Containing Sensitive Information vulnerability in Apache Camel gRPC component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. When a route behind a gRPC consumer failed, the exception's message was placed into the gRPC status description. Unlike the status cause, which stays local to the server, the description is transmitted to the calling client, so an external caller able to provoke a failure could read the internal error message. What that discloses depends on the exception, and in practice includes class and package names, paths, host names and connection detail carried in messages. This is the gRPC member of the same unmuted-consumer-exception family as the knative, mina and CXF advisories published alongside it. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. A muteException consumer option, defaulting to true, puts a generic description in the status instead of the route exception's message. Set muteException=false to restore the previous output. For deployments that cannot upgrade immediately, map failures onto an explicit status in an onException handler so the framework never copies the exception message into the description.

Last activity 19 Oct 2026. Patch Forecast updates every hour.