Patch Forecast
Yellow warning
Plan into this sprint.

CVE-2026-85243

Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP…

Risk score
42/100
CVSS
5.9 v3.1
Exploit chance (30 days)
0.4%
Published
19 Oct 2026

Open in the live forecast Today's forecast

What to know

What it is
Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. unmarshal() verified the modification detection code only when the message was an OpenPGP symmetrically encrypted integrity protected da…
Affected
Apache Camel before 4.18.5, 4.22.1
Fix
Upgrade Apache Camel to 4.18.5 or 4.22.1 (whichever matches your release line), or later.
Exploitation
No known exploitation

Story map

Story map: Apache CamelTHE FLAWSTHE FIXCVE-2026-85243Improper Validation ofIntegrity Check Valuevulnerability in Apache Camel…CVSS 5.9 · EPSS 0%CVE-2026-79986Path traversalCVSS 9.1 · EPSS 1%CVE-2026-78162Unsafe deserialisation can leadto remote code executionCVSS 9.8 · EPSS 1%CVE-2026-79983Path traversalCVSS 9.1 · EPSS 1%Upgrade Apache Camel4.18.5 · 4.22.1 · 4.23.0or later on your release lineWho is exposed{'products': ['Apache Camel'],'packages': [], 'versions': ['4.0.0before 4.18.5', '4.19.0 before4.22.1']}RED · ACT TODAYApache CamelApache Camel has a 'PathTraversal' vulnerability in itsAzure Files component, allowingan attacker to access filesoutside the intended directory.An attacker could read, write,or delete files on the remote…Where it standsNo known exploitationCONNECTS TOSame weaknessCWE-354 (CWE-354)17 other warnings in 30 days →Same productEarlier Apache Camel warnings23 in the last 90 days →
Story map: the flaws, the fix, how it unfolded and what it connects to. Boxes link to the record or article.

At a glance

Apache Camel: Red, act today. Apache Camel has a 'Path Traversal' vulnerability in its Azure Files component, allowing an attacker to access files outside the intended directory. An attacker could read, write, or delete files on the remote server.

The flaws

  • CVE-2026-85243: Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP… (CVSS 5.9 · EPSS 0%)
  • CVE-2026-79986: Path traversal (CVSS 9.1 · EPSS 1%)
  • CVE-2026-78162: Unsafe deserialisation can lead to remote code execution (CVSS 9.8 · EPSS 1%)
  • CVE-2026-79983: Path traversal (CVSS 9.1 · EPSS 1%)

The fix

Upgrade Apache Camel: 4.18.5 · 4.22.1 · 4.23.0 or later on your release line

Who is exposed: {'products': ['Apache Camel'], 'packages': [], 'versions': ['4.0.0 before 4.18.5', '4.19.0 before 4.22.1']}

Where it stands

  • No known exploitation

Connects to

Why it is Yellow

  • CVSS 5.9 medium

References

Original description

Improper Validation of Integrity Check Value vulnerability in Apache Camel Crypto PGP component. This issue affects Apache Camel: from 4.0.0 before 4.18.5, from 4.19.0 before 4.22.1. unmarshal() verified the modification detection code only when the message was an OpenPGP symmetrically encrypted integrity protected data packet. The older symmetrically encrypted data packet carries no such code, and OpenPGP's CFB mode is malleable without one, so a message using that packet skipped the check altogether. The packet type is chosen by whoever produced the message, which left the sender - or anyone able to rewrite the message in transit - deciding whether the integrity check applied at all. The existing integrity option governs marshalling only and had no decrypt-side counterpart, so a deployment could not require integrity protection on the messages it accepted. Upgrade to Apache Camel 4.23.0, which fixes the issue. Users on the 4.18.x LTS releases stream should upgrade to 4.18.5. Users on the 4.22.x LTS releases stream should upgrade to 4.22.1. A requireIntegrityProtection option, defaulting to true, now rejects a message that is not integrity protected. Note that signatureVerificationOption still defaults to optional, so a message carrying no signature is accepted; the two options together are what give a decrypted message authenticity and not only confidentiality. For deployments that cannot upgrade immediately, reject messages that do not use the integrity protected packet before they reach the data format. Routes that must interoperate with a sender still emitting the legacy packet should set requireIntegrityProtection=false after upgrading, and treat the decrypted content as unauthenticated.

Last activity 19 Oct 2026. Patch Forecast updates every hour.