CVE-2026-70654
libvips is a fast image processing library with low memory needs
- Risk score
- 40/100
- CVSS
- 5.8 v4.0
- Exploit chance (30 days)
- 0.1%
- Published
- 20 Aug 2026
Open in the live forecast Today's forecast
What to know
- What it is
- libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX …
- Affected
- Canonical Ubuntu Linux before 8.18.3
- Fix
- Upgrade Canonical Ubuntu Linux to 8.18.3 or later.
- Exploitation
- No known exploitation
Story map
At a glance
Canonical Ubuntu Linux: Red, act today. A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and the root directive or access log format references the map's regex capture variables before referencing the map output variable. An unauthenticated attacker can exploit this vulnerability by sending crafted HTTP requests, causing a heap buffer overflow in the NGINX worker process leading to a restart, or potential…
The flaws
- CVE-2026-70654: Libvips is a fast image processing library with low memory needs (CVSS 5.8 · EPSS 0%)
- CVE-2026-93479: Heap buffer overflow can lead to remote code execution (CVSS 8.1 · EPSS 1%)
- CVE-2026-15176: Heap buffer overflow can lead to remote code execution (CVSS 8.1 · EPSS 1%)
- CVE-2026-97205: NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module (CVSS 8.1 · EPSS 1%)
The fix
Upgrade Canonical Ubuntu Linux: 8.18.3 or later on your release line
Who is exposed: {'products': ['NGINX Plus', 'NGINX Open Source'], 'packages': [], 'versions': []}
Where it stands
- No known exploitation
How it unfolded
- 26 Oct, Ubuntu security notices (official): USN-8955-1: nginx vulnerabilities
- 3 Nov, Ubuntu security notices (official): USN-8994-1: libvips vulnerabilities
Connects to
- Same weakness: Heap buffer overflow (CWE-122). 397 other warnings in 30 days
- Same product: Earlier Canonical Ubuntu Linux warnings. 83 in the last 90 days
Why it is Yellow
- CVSS 5.8 medium
- Named in a government or vendor bulletin
Government and vendor bulletins
References
- https://ubuntu.com/security/notices/USN-8994-1
- https://github.com/libvips/libvips/commit/80e021c6cdda0f80b756c2109d99839c94c03258
- https://github.com/libvips/libvips/pull/5038
- https://github.com/libvips/libvips/releases/tag/v8.18.3
- https://github.com/libvips/libvips/security/advisories/GHSA-rjmm-3qch-m9rg
Original description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, applications that define unusual custom libvips sources and use them to process untrusted uncompressed PPM images can trigger a max/min error in vips_source_read_to_memory in libvips/iofuncs/source.c. The function uses VIPS_MAX instead of VIPS_MIN when selecting the remaining read size, allowing up to 4032 bytes to be written beyond the allocated heap buffer and causing memory corruption or a process crash. This issue is fixed in version 8.18.3.
Last activity 3 Nov 2026. Patch Forecast updates every hour.