CVE-2026-70651
libvips is a fast image processing library with low memory needs
- Risk score
- 46/100
- CVSS
- 6.9 v4.0
- Published
- 20 Aug 2026
Open in the live forecast Today's forecast
What to know
- What it is
- libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built without libtiff support but with ImageMagick support can overflow the combined frame height while loading a crafted multi-page TIFF through VipsForeignLoadMagick. The vulnerable calculations in libvips/foreign/magi…
- Affected
- Canonical Ubuntu Linux before 8.18.3
- Fix
- Upgrade Canonical Ubuntu Linux to 8.18.3 or later.
- Exploitation
- No known exploitation
Story map
At a glance
Canonical Ubuntu Linux: Red, act today. A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and the root directive or access log format references the map's regex capture variables before referencing the map output variable. An unauthenticated attacker can exploit this vulnerability by sending crafted HTTP requests, causing a heap buffer overflow in the NGINX worker process leading to a restart, or potential…
The flaws
- CVE-2026-70651: Libvips is a fast image processing library with low memory needs (CVSS 6.9)
- CVE-2026-93479: Heap buffer overflow can lead to remote code execution (CVSS 8.1 · EPSS 1%)
- CVE-2026-15176: Heap buffer overflow can lead to remote code execution (CVSS 8.1 · EPSS 1%)
- CVE-2026-97205: NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module (CVSS 8.1 · EPSS 1%)
The fix
Upgrade Canonical Ubuntu Linux: 8.18.3 or later on your release line
Who is exposed: {'products': ['NGINX Plus', 'NGINX Open Source'], 'packages': [], 'versions': []}
Where it stands
- No known exploitation
How it unfolded
- 26 Oct, Ubuntu security notices (official): USN-8955-1: nginx vulnerabilities
- 3 Nov, Ubuntu security notices (official): USN-8994-1: libvips vulnerabilities
Connects to
- Same weakness: CWE-680 (CWE-680). 2 other warnings in 30 days
- Same product: Earlier Canonical Ubuntu Linux warnings. 96 in the last 90 days
Why it is Yellow
- CVSS 6.9 medium
- Named in a government or vendor bulletin
Government and vendor bulletins
References
- https://ubuntu.com/security/notices/USN-8994-1
- https://github.com/libvips/libvips/commit/05719ca3d5852acdeb6714de2e8e769c9a5d2c11
- https://github.com/libvips/libvips/pull/5040
- https://github.com/libvips/libvips/releases/tag/v8.18.3
- https://github.com/libvips/libvips/security/advisories/GHSA-7p29-wg2h-36q4
Original description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, libvips built without libtiff support but with ImageMagick support can overflow the combined frame height while loading a crafted multi-page TIFF through VipsForeignLoadMagick. The vulnerable calculations in libvips/foreign/magick6load.c and libvips/foreign/magick7load.c multiply the per-page Ysize by n_frames without a checked bound, which can cause a heap buffer over-read and process crash. Most package-manager builds include libtiff and do not use this affected fallback path. This issue is fixed in version 8.18.3.
Last activity 3 Nov 2026. Patch Forecast updates every hour.