CVE-2026-69242
libvips is a fast image processing library with low memory needs
- Risk score
- 55/100
- CVSS
- 8.4 v4.0
- Published
- 20 Aug 2026
Open in the live forecast Today's forecast
What to know
- What it is
- libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, a crafted many-band TIFF processed through VipsForeignLoadTiff can evade scanline validation in libvips/iofuncs/image.c and cause an integer overflow in vips_image_sanity. The resulting buffer-region calculation can access attac…
- Affected
- Canonical Ubuntu Linux before 8.18.3
- Fix
- Upgrade Canonical Ubuntu Linux to 8.18.3 or later.
- Exploitation
- No known exploitation
Story map
At a glance
Canonical Ubuntu Linux: Red, act today. A vulnerability exists in NGINX Plus and NGINX Open Source when a map directive uses regex matching and the root directive or access log format references the map's regex capture variables before referencing the map output variable. An unauthenticated attacker can exploit this vulnerability by sending crafted HTTP requests, causing a heap buffer overflow in the NGINX worker process leading to a restart, or potential…
The flaws
- CVE-2026-69242: Libvips is a fast image processing library with low memory needs (CVSS 8.4)
- CVE-2026-93479: Heap buffer overflow can lead to remote code execution (CVSS 8.1 · EPSS 1%)
- CVE-2026-15176: Heap buffer overflow can lead to remote code execution (CVSS 8.1 · EPSS 1%)
- CVE-2026-97205: NGINX Plus and NGINX Open Source have a vulnerability in the ngx_http_core_module module (CVSS 8.1 · EPSS 1%)
The fix
Upgrade Canonical Ubuntu Linux: 8.18.3 or later on your release line
Who is exposed: {'products': ['NGINX Plus', 'NGINX Open Source'], 'packages': [], 'versions': []}
Where it stands
- No known exploitation
How it unfolded
- 26 Oct, Ubuntu security notices (official): USN-8955-1: nginx vulnerabilities
- 3 Nov, Ubuntu security notices (official): USN-8994-1: libvips vulnerabilities
Connects to
- Same weakness: Heap buffer overflow (CWE-122). 398 other warnings in 30 days
- Same product: Earlier Canonical Ubuntu Linux warnings. 96 in the last 90 days
Why it is Yellow
- CVSS 8.4 high
- Named in a government or vendor bulletin
Government and vendor bulletins
References
- https://ubuntu.com/security/notices/USN-8994-1
- https://github.com/libvips/libvips/commit/c72f50927413cd2451837d9813f954bc5d88f548
- https://github.com/libvips/libvips/pull/5012
- https://github.com/libvips/libvips/releases/tag/v8.18.3
- https://github.com/libvips/libvips/security/advisories/GHSA-9rwc-f68v-4482
Original description
libvips is a fast image processing library with low memory needs. Prior to version 8.18.3, a crafted many-band TIFF processed through VipsForeignLoadTiff can evade scanline validation in libvips/iofuncs/image.c and cause an integer overflow in vips_image_sanity. The resulting buffer-region calculation can access attacker-controlled negative offsets in mmap-resident allocations, allowing reads or writes of other image data, possible data disclosure through uncompressed .v output, and likely process crashes. Remote code execution has not been demonstrated but cannot be ruled out. This issue is fixed in version 8.18.3.
Last activity 3 Nov 2026. Patch Forecast updates every hour.