CVE-2026-118254 · GHSA-r5wg-q8fc-p6w2
Highcharts Grid parses pagination language options as HTML
- Risk score
- 57/100
- CVSS
- 8.6 v4.0
- Published
- 28 Oct 2026
Open in the live forecast Today's forecast
What to know
- What it is
- Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin whe…
- Affected
- @highcharts/grid-lite (npm) >= 2.0.0, <= 3.1.0; @highcharts/grid-pro (npm) >= 2.0.0, <= 3.1.0
- Fix
- Upgrade @highcharts/grid-lite to 3.2.0; @highcharts/grid-pro to 3.2.0 or later.
- Exploitation
- No known exploitation
Story map
At a glance
@highcharts/grid-lite: Yellow, plan it in. Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin whe…
The flaws
- CVE-2026-118254: Highcharts Grid parses pagination language options as HTML (CVSS 8.6)
- CVE-2026-118242: Highcharts Grid: custom icon definition objects written with raw `setAttribute` on `<path>` (CVSS 8.5)
The fix
Upgrade @highcharts/grid-lite: 3.2.0 or later on your release line
Who is exposed: @highcharts/grid-lite (npm) >= 2.0.0, <= 3.1.0; @highcharts/grid-pro (npm) >= 2.0.0, <= 3.1.0
Where it stands
- No known exploitation
Connects to
- Same weakness: Cross-site scripting (CWE-79). 400 other warnings in 30 days
Why it is Yellow
- CVSS 8.6 high
- On your watchlist: npm
Affected packages
| Package | Ecosystem | Vulnerable | Fixed in |
|---|---|---|---|
| @highcharts/grid-lite | npm | >= 2.0.0, <= 3.1.0 | 3.2.0 |
| @highcharts/grid-pro | npm | >= 2.0.0, <= 3.1.0 | 3.2.0 |
References
- https://github.com/advisories/GHSA-r5wg-q8fc-p6w2
- https://github.com/highcharts/highcharts/security/advisories/GHSA-r5wg-q8fc-p6w2
- https://github.com/highcharts/highcharts/commit/1e8ded84d52191883965641b863cf0c73eb759aa
- https://github.com/highcharts/highcharts/releases/tag/grid-v3.2.0
- https://github.com/advisories/GHSA-r5wg-q8fc-p6w2
Original description
Highcharts JS is a JavaScript charting library based on SVG. From 2.0.0 until 3.2.0, Highcharts Grid writes pagination language strings into the DOM as markup instead of text. An attacker who controls the Grid language configuration can provide elements with event handlers, which execute in the hosting page origin when pagination controls render. Exploitation requires pagination to be enabled but does not require additional user interaction. This issue is fixed in 3.2.0.
Last activity 28 Oct 2026. Patch Forecast updates every hour.