Patch Forecast
Yellow warning
Plan into this sprint.

CVE-2026-106456 · GHSA-472h-9c5j-prrr

Backstage: Inconsistent credential enforcement for overlapping proxy routes

Risk score
47/100
CVSS
6.5 v3.1
Exploit chance (30 days)
0.2%
Published
6 Oct 2026

Open in the live forecast Today's forecast

What to know

What it is
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent pa…
Affected
@backstage/plugin-proxy-backend (npm) >= 0.5.0, < 0.6.18
Fix
Upgrade @backstage/plugin-proxy-backend to 0.6.18 or later.
Exploitation
No known exploitation

Story map

Story map: @backstage/plugin-proxy-backendTHE FLAWSTHE FIXCVE-2026-106456Backstage: Inconsistentcredential enforcement foroverlapping proxy routesCVSS 6.5 · EPSS 0%CVE-2026-106491Backstage: Improper inputvalidation in proxy-backendCVSS 6.4 · EPSS 0%Upgrade…0.6.18 · 0.6.17or later on your release lineWho is exposed@backstage/plugin-proxy-backend (npm) < 0.6.17YELLOW · PLAN IT IN@backstage/plugin-proxy-backendBackstage is an open frameworkfor building developer portals.Prior to 0.6.17, the@backstage/plugin-proxy-backend package is affected byimproper input validation inproxy-backend. An…Where it standsNo known exploitationCONNECTS TOSame weaknessIncorrect authorisation (CWE-863)350 other warnings in 30 days →
Story map: the flaws, the fix, how it unfolded and what it connects to. Boxes link to the record or article.

At a glance

@backstage/plugin-proxy-backend: Yellow, plan it in. Backstage is an open framework for building developer portals. Prior to 0.6.17, the @backstage/plugin-proxy-backend package is affected by improper input validation in proxy-backend. An authenticated Backstage user could craft a request URL that causes the proxy-backend to forward the request to a path outside the con…

The flaws

  • CVE-2026-106456: Backstage: Inconsistent credential enforcement for overlapping proxy routes (CVSS 6.5 · EPSS 0%)
  • CVE-2026-106491: Backstage: Improper input validation in proxy-backend (CVSS 6.4 · EPSS 0%)

The fix

Upgrade @backstage/plugin-proxy-backend: 0.6.18 · 0.6.17 or later on your release line

Who is exposed: @backstage/plugin-proxy-backend (npm) < 0.6.17

Where it stands

  • No known exploitation

Connects to

Why it is Yellow

  • CVSS 6.5 medium
  • On your watchlist: npm

Affected packages

PackageEcosystemVulnerableFixed in
@backstage/plugin-proxy-backendnpm>= 0.5.0, < 0.6.180.6.18

References

Original description

Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.

Last activity 6 Oct 2026. Patch Forecast updates every hour.