CVE-2026-95860
node-opcua is an OPC UA implementation for TypeScript and Node.js
- Risk score
- 70/100
- CVSS
- 9.1 v3.1
- Published
- 3 Nov 2026
Open in the live forecast Today's forecast
What to know
- What it is
- node-opcua has a critical vulnerability (CVSS 9.1) where an anonymous network client can bypass access control and write variables or call methods due to incorrect handling of namespace permissions.
- Affected
- {'products': ['node-opcua'], 'packages': [], 'versions': ['2.42.0', '2.180.0']}
- Fix
- Upgrade to version 2.180.0 or later
- Exploitation
- No known exploitation
Why it is Amber
- CVSS 9.1 critical
- Remotely exploitable without logging in
- On your watchlist: node.js
References
Original description
node-opcua is an OPC UA implementation for TypeScript and Node.js. From 2.42.0 until 2.180.0, namespace-level access control configured through setDefaultRolePermissions is not honored by the runtime enforcement path for nodes without explicit per-node RolePermissions. SessionContext.getApplicableRolePermissions reads a missing or null DefaultRolePermissions metadata value instead of the configured namespace field, and the null result is treated permissively. An anonymous network client can consequently write variables with CurrentWrite access or call bound methods when an operator configured a restrictive namespace default and relied on inheritance. Servers with no declared policy, nodes with explicit per-node permissions, and correctly bound programmatic namespace metadata are outside the authorization-bypass case. This issue is fixed in version 2.180.0.
Last activity 3 Nov 2026. Patch Forecast updates every hour.