Patch Forecast
Amber warning
Patch this week.

CVE-2026-119923

A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension…

Risk score
74/100
CVSS
9.8 v3.1
Published
6 Nov 2026

Open in the live forecast Today's forecast

What to know

What it is
A heap-based buffer overflow in the TDS prelogin parser in Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and Amazon Aurora PostgreSQL with Babelfish allows remote attackers to execute arbitrary OS commands as the database process user via a specially crafted malformed TDS prelogin packet. This could lead to code execution and high impact.
Affected
{'products': ['Babelfish for PostgreSQL', 'Amazon Aurora PostgreSQL'], 'packages': [], 'versions': ['1.0-1.5', '2.1-2.15', '3.1-3.12', '4.0-4.8', '5.1-5.4', '13.9.16 (1.5.5)', '13.23.3 (1.17.2)', '14.6.16 (2.3.5)', '14.17.8 (2.12.4)', '14.18.6 (2.13.3)', '14.19.5 (2.14.2)', '14.20.5 (2.15.2)', '14.22.3 (2.16.2)']}
Fix
Upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later, or upgrade Amazon Aurora PostgreSQL with Babelfish to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.2), or restrict network access to the TDS port (default 1433).
Exploitation
No known exploitation

Not confirmed. 2.16.2 isn't in the advisory. Check the vendor's advisory before acting on this.

Why it is Amber

  • CVSS 9.8 critical
  • Remotely exploitable without logging in
  • On your watchlist: postgresql

References

Original description

A heap-based buffer overflow in the TDS prelogin parser in the Babelfish for PostgreSQL extension versions 1.0-1.5, 2.1-2.15, 3.1-3.12, 4.0-4.8, 5.1-5.4 and in Amazon Aurora PostgreSQL with Babelfish might allow remote attackers to execute arbitrary OS commands as the database process user via a specially crafted malformed TDS prelogin packet to the TDS port. This record consolidates a related NULL-pointer-dereference finding in the same prelogin parser. To remediate this issue, we recommend users upgrade to Babelfish for PostgreSQL extension versions 4.10, 5.6, 6.1 or later. As a workaround, restrict network access to the TDS port (default 1433). Customers using Amazon Aurora PostgreSQL with Babelfish should upgrade their cluster to Aurora PostgreSQL 13.9.16 (1.5.5), 13.23.3 (1.17.2), 14.6.16 (2.3.5), 14.17.8 (2.12.4), 14.18.6 (2.13.3), 14.19.5 (2.14.2), 14.20.5 (2.15.2), 14.22.3 (2.16.1), 14.23.1 (2.17.0), 15.10.8 (3.8.4), 15.12.8 (3.9.4), 15.13.6 (3.10.3), 15.14.5 (3.11.2), 15.15.5 (3.12.2), 15.17.3 (3.13.1), 15.18.1 (3.14.0), 16.8.8 (4.5.5), 16.9.6 (4.6.3), 16.10.5 (4.7.2), 16.11.5 (4.8.2), 16.13.3 (4.9.1), 16.14.1 (4.10.0), 17.4.8 (5.1.4), 17.5.6 (5.2.3), 17.6.5 (5.3.2), 17.7.5 (5.4.2), 17.9.3 (5.5.1), 17.10.1 (5.6.0), 18.3.4 (6.0.2), 18.4.1 (6.1.0) or later, and apply any pending maintenance to ensure they are on the latest patch.

Last activity 6 Nov 2026. Patch Forecast updates every hour.