CVE-2026-113687
Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator…
- Risk score
- 66/100
- CVSS
- 9.8 v3.1
- Exploit chance (30 days)
- 0.2%
- Published
- 2 Nov 2026
Open in the live forecast Today's forecast
What to know
- What it is
- Apache Syncope has a vulnerability where an administrator can create a malicious Groovy class to run untrusted code on a separate thread, bypassing the Groovy security sandbox. An attacker could exploit this to gain high privileges, read, modify or delete data, and disrupt services.
- Affected
- {'products': ['Apache Syncope'], 'packages': [], 'versions': ['3.0.0-M0 through 3.0.16', '4.0.0-M0 through 4.0.8', '4.1.0-M0 through 4.1.3']}
- Fix
- Upgrade to version 4.0.9 / 4.1.4
- Exploitation
- No known exploitation
Why it is Amber
- CVSS 9.8 critical
- Remotely exploitable without logging in
References
Original description
Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements for Implementations can create a malicious Groovy class running untrusted code on a separate Thread, thus bypassing the Groovy security sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0-M0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue.
Last activity 2 Nov 2026. Patch Forecast updates every hour.