CVE-2026-109083
Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator with…
- Risk score
- 66/100
- CVSS
- 9.8 v3.1
- Exploit chance (30 days)
- 0.2%
- Published
- 2 Nov 2026
Open in the live forecast Today's forecast
What to know
- What it is
- Apache Syncope has a vulnerability where an administrator can import arbitrary BPMN process definitions via the REST API, allowing an attacker to execute JUEL expressions directly on the server. This allows an attacker to gain high privileges, including the ability to read, modify, and delete sensitive data.
- Affected
- {'products': ['Apache Syncope'], 'packages': [], 'versions': ['3.0.0-M0 through 3.0.16', '4.0.0-M0 through 4.0.8', '4.1.0 through 4.1.3']}
- Fix
- Upgrade to version 4.0.9 / 4.1.4, which reject BPMN definitions including expression attributes.
- Exploitation
- No known exploitation
Why it is Amber
- CVSS 9.8 critical
- Remotely exploitable without logging in
References
Original description
Improper isolation or compartmentalization vulnerability in Apache Syncope. An administrator with adequate entitlements can import arbitrary BPMN process definitions via the REST API and then start the process. When a BPMN process containing a JUEL expression is imported and started, the expression is executed directly on the server, with no sandbox. This issue affects Apache Syncope: from 3.0.0-M0 through 3.0.16, from 4.0.0-M0 through 4.0.8, from 4.1.0 through 4.1.3. Users are recommended to upgrade to version 4.0.9 / 4.1.4, which fix this issue by rejecting BPMN definitions including expression attributes.
Last activity 2 Nov 2026. Patch Forecast updates every hour.